Skip to content

← Actionable
Critical, CVSS 9.3amended

Unsafe deserialization in owlmixin

CVE-2017-16618GHSA-ccmq-qvcp-5mrm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (owlmixin 2.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI owlmixin

    Affected
    < 2.0.0
    Fixed in
    2.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2017-16618: 4.47% estimated exploitation activity in the next 30 days; percentile 91.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An exploitable vulnerability exists in the YAML loading functionality of util.py in OwlMixin before 2.0.0a12. A "Load YAML" string or file (aka loadyaml or loadyamlf) can execute arbitrary Python commands resulting in command execution because load is used where safeload should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-ccmq-qvcp-5mrm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-ccmq-qvcp-5mrm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-16618

Advisory: Unsafe deserialization in owlmixin
IDs: CVE-2017-16618, GHSA-ccmq-qvcp-5mrm
Record: https://patchnext.com/advisories/cve-2017-16618 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: owlmixin 2.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI owlmixin: affected < 2.0.0; fixed in 2.0.0

## Suggested inspection (read-only)
- `python -m pip show owlmixin`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on owlmixin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ccmq-qvcp-5mrm (OSV record GHSA-ccmq-qvcp-5mrm lists affected ranges: PyPI owlmixin >=0 <2.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-ccmq-qvcp-5mrm (GitHub-reviewed advisory GHSA-ccmq-qvcp-5mrm lists affected ranges: PyPI owlmixin >=0 <2.0.0)

Commands are suggestions: review each one before running it.

Loading voting…