Skip to content

← Actionable
Critical, CVSS 9.3amended

Unsafe pyyaml load usage in PyAnyAPI

CVE-2017-16616GHSA-vg8g-jpm9-jh8r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyanyapi 0.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyanyapi

    Affected
    < 0.6.1
    Fixed in
    0.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2017-16616: 3.62% estimated exploitation activity in the next 30 days; percentile 89.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An exploitable vulnerability exists in the YAML parsing functionality in the YAMLParser method in Interfaces.py in PyAnyAPI before 0.6.1. A YAML parser can execute arbitrary Python commands resulting in command execution because load is used where safeload should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vg8g-jpm9-jh8r

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vg8g-jpm9-jh8r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-16616

Advisory: Unsafe pyyaml load usage in PyAnyAPI
IDs: CVE-2017-16616, GHSA-vg8g-jpm9-jh8r
Record: https://patchnext.com/advisories/cve-2017-16616 (revision 3, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyanyapi 0.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyanyapi: affected < 0.6.1; fixed in 0.6.1

## Suggested inspection (read-only)
- `python -m pip show pyanyapi`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyanyapi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vg8g-jpm9-jh8r (OSV record GHSA-vg8g-jpm9-jh8r lists affected ranges: PyPI pyanyapi >=0 <0.6.1 (fixed))
- Verified: https://github.com/advisories/GHSA-vg8g-jpm9-jh8r (GitHub-reviewed advisory GHSA-vg8g-jpm9-jh8r lists affected ranges: PyPI pyanyapi >=0 <0.6.1)

Commands are suggestions: review each one before running it.

Loading voting…