OpenStack Swauth object/proxy server writing Auth Token to log file
CVE-2017-16613GHSA-qhq8-xwqv-pvv9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (swauth 1.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI swauth
- Affected
- < 1.3.0
- Fixed in
- 1.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qhq8-xwqv-pvv9 lists affected ranges: PyPI swauth >=0 <1.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qhq8-xwqv-pvv9 lists affected ranges: PyPI swauth >=0 <1.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2017-16613: 8.42% estimated exploitation activity in the next 30 days; percentile 95.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in middleware.py in OpenStack Swauth through 1.2.0 when used with OpenStack Swift through 2.15.1. The Swift object store and proxy server are saving (unhashed) tokens retrieved from the Swauth middleware authentication mechanism to a log file as part of a GET URI. This allows attackers to bypass authentication by inserting a token into an X-Auth-Token header of a new request. NOTE: github.com/openstack/swauth URLs do not mean that Swauth is maintained by an official OpenStack project team.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-qhq8-xwqv-pvv9
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-qhq8-xwqv-pvv9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-16613 Advisory: OpenStack Swauth object/proxy server writing Auth Token to log file IDs: CVE-2017-16613, GHSA-qhq8-xwqv-pvv9 Record: https://patchnext.com/advisories/cve-2017-16613 (revision 3, source checked 26 Oct 2026, 13:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: swauth 1.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI swauth: affected < 1.3.0; fixed in 1.3.0 ## Suggested inspection (read-only) - `python -m pip show swauth`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on swauth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qhq8-xwqv-pvv9 (OSV record GHSA-qhq8-xwqv-pvv9 lists affected ranges: PyPI swauth >=0 <1.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-qhq8-xwqv-pvv9 (GitHub-reviewed advisory GHSA-qhq8-xwqv-pvv9 lists affected ranges: PyPI swauth >=0 <1.3.0) Commands are suggestions: review each one before running it.
Loading voting…