yajl-ruby gem Denial of Service vulnerability
CVE-2017-16516GHSA-wwh7-4jw9-33x6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yajl-ruby 1.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems yajl-ruby
- Affected
- < 1.3.1
- Fixed in
- 1.3.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wwh7-4jw9-33x6 lists affected ranges: RubyGems yajl-ruby >=0 <1.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2017-16516: 3.80% estimated exploitation activity in the next 30 days; percentile 90.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In the yajl-ruby gem 1.3.0 for Ruby, when a crafted JSON file is supplied to Yajl::Parser.new.parse, the whole ruby process crashes with a SIGABRT in the yajlstringdecode function in yajlencode.c. This results in the whole ruby process terminating and potentially a denial of service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wwh7-4jw9-33x6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-16516 Advisory: yajl-ruby gem Denial of Service vulnerability IDs: CVE-2017-16516, GHSA-wwh7-4jw9-33x6 Record: https://patchnext.com/advisories/cve-2017-16516 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yajl-ruby 1.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems yajl-ruby: affected < 1.3.1; fixed in 1.3.1 ## Suggested inspection (read-only) - RubyGems yajl-ruby: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yajl-ruby. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wwh7-4jw9-33x6 (GitHub-reviewed advisory GHSA-wwh7-4jw9-33x6 lists affected ranges: RubyGems yajl-ruby >=0 <1.3.1) Commands are suggestions: review each one before running it.
Loading voting…