superagent vulnerable to zip bomb attacks
CVE-2017-16129GHSA-8225-6cvr-8pqp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (superagent 3.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm superagent
- Affected
- < 3.7.0
- Fixed in
- 3.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8225-6cvr-8pqp lists affected ranges: npm superagent >=0 <3.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8225-6cvr-8pqp lists affected ranges: npm superagent >=0 <3.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2017-16129: 1.74% estimated exploitation activity in the next 30 days; percentile 77.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of superagent do not check the post-decompression size of ZIP compressed HTTP responses prior to decompressing. This results in the package being vulnerable to a ZIP bomb attack, where an extremely small ZIP file becomes many orders of magnitude larger when decompressed. This may result in unrestrained CPU/Memory/Disk consumption, causing a denial of service condition. Recommendation Update to version 3.7.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8225-6cvr-8pqp
- Revision 1 · created ·
Published from osv record GHSA-8225-6cvr-8pqp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-16129 Advisory: superagent vulnerable to zip bomb attacks IDs: CVE-2017-16129, GHSA-8225-6cvr-8pqp Record: https://patchnext.com/advisories/cve-2017-16129 (revision 2, source checked 26 Oct 2026, 12:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: superagent 3.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm superagent: affected < 3.7.0; fixed in 3.7.0 ## Suggested inspection (read-only) - `npm ls superagent --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on superagent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8225-6cvr-8pqp (OSV record GHSA-8225-6cvr-8pqp lists affected ranges: npm superagent >=0 <3.7.0 (fixed)) - Verified: https://github.com/advisories/GHSA-8225-6cvr-8pqp (GitHub-reviewed advisory GHSA-8225-6cvr-8pqp lists affected ranges: npm superagent >=0 <3.7.0) Commands are suggestions: review each one before running it.
Loading voting…