Regular Expression Denial of Service in slug
CVE-2017-16117GHSA-jxqq-cqm6-pfq9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (slug 0.9.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm slug
- Affected
- <= 0.9.1
- Fixed in
- 0.9.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jxqq-cqm6-pfq9 lists affected ranges: npm slug >=0 <0.9.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jxqq-cqm6-pfq9 lists affected ranges: npm slug >=0 <=0.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2017-16117: 1.56% estimated exploitation activity in the next 30 days; percentile 75.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of slug are vulnerable to a regular expression denial of service when parsing untrusted user input. The issue is low severity, as it takes 50,000 characters to cause the event loop to block for 2 seconds, About 50k characters can block the event loop for 2 seconds. Recommendation Update to version 0.9.2 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jxqq-cqm6-pfq9
- Revision 1 · created ·
Published from osv record GHSA-jxqq-cqm6-pfq9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-16117 Advisory: Regular Expression Denial of Service in slug IDs: CVE-2017-16117, GHSA-jxqq-cqm6-pfq9 Record: https://patchnext.com/advisories/cve-2017-16117 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: slug 0.9.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm slug: affected <= 0.9.1; fixed in 0.9.2 ## Suggested inspection (read-only) - `npm ls slug --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on slug. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jxqq-cqm6-pfq9 (OSV record GHSA-jxqq-cqm6-pfq9 lists affected ranges: npm slug >=0 <0.9.2 (fixed)) - Verified: https://github.com/advisories/GHSA-jxqq-cqm6-pfq9 (GitHub-reviewed advisory GHSA-jxqq-cqm6-pfq9 lists affected ranges: npm slug >=0 <=0.9.1) Commands are suggestions: review each one before running it.
Loading voting…