Skip to content

← Actionable
Unratedamended

Command Injection in dns-sync

CVE-2017-16100GHSA-jcw8-r9xm-32c6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dns-sync 0.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm dns-sync

    Affected
    < 0.1.1
    Fixed in
    0.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2017-16100: 5.05% estimated exploitation activity in the next 30 days; percentile 92.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of dns-sync have an arbitrary command execution vulnerability in the resolve() method. Recommendation - Use an alternative dns resolver - Do not allow untrusted input into dns-sync.resolve()

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jcw8-r9xm-32c6

  2. Revision 1 · created ·

    Published from osv record GHSA-jcw8-r9xm-32c6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-16100

Advisory: Command Injection in dns-sync
IDs: CVE-2017-16100, GHSA-jcw8-r9xm-32c6
Record: https://patchnext.com/advisories/cve-2017-16100 (revision 2, source checked 26 Oct 2026, 12:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dns-sync 0.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm dns-sync: affected < 0.1.1; fixed in 0.1.1

## Suggested inspection (read-only)
- `npm ls dns-sync --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dns-sync.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jcw8-r9xm-32c6 (OSV record GHSA-jcw8-r9xm-32c6 lists affected ranges: npm dns-sync >=0 <0.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-jcw8-r9xm-32c6 (GitHub-reviewed advisory GHSA-jcw8-r9xm-32c6 lists affected ranges: npm dns-sync >=0 <0.1.1)

Commands are suggestions: review each one before running it.

Loading voting…