Directory Traversal in list-n-stream
CVE-2017-16084GHSA-23vf-5g53-hm9q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (list-n-stream 0.0.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm list-n-stream
- Affected
- <= 0.0.10
- Fixed in
- 0.0.11
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-23vf-5g53-hm9q lists affected ranges: npm list-n-stream >=0 <0.0.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-23vf-5g53-hm9q lists affected ranges: npm list-n-stream >=0 <=0.0.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2017-16084: 1.97% estimated exploitation activity in the next 30 days; percentile 80.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of list-n-stream resolve relative file paths, resulting in a directory traversal vulnerability. A malicious actor can use this vulnerability to access files outside of the intended directory root, which may result in the disclosure of private files on the vulnerable system. Example request: Recommendation Update to version 0.0.11 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-23vf-5g53-hm9q
- Revision 1 · created ·
Published from osv record GHSA-23vf-5g53-hm9q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-16084 Advisory: Directory Traversal in list-n-stream IDs: CVE-2017-16084, GHSA-23vf-5g53-hm9q Record: https://patchnext.com/advisories/cve-2017-16084 (revision 2, source checked 26 Oct 2026, 12:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: list-n-stream 0.0.11. A vendor fix does not mean a deployment is fixed. ## Affected components - npm list-n-stream: affected <= 0.0.10; fixed in 0.0.11 ## Suggested inspection (read-only) - `npm ls list-n-stream --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on list-n-stream. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-23vf-5g53-hm9q (OSV record GHSA-23vf-5g53-hm9q lists affected ranges: npm list-n-stream >=0 <0.0.11 (fixed)) - Verified: https://github.com/advisories/GHSA-23vf-5g53-hm9q (GitHub-reviewed advisory GHSA-23vf-5g53-hm9q lists affected ranges: npm list-n-stream >=0 <=0.0.10) Commands are suggestions: review each one before running it.
Loading voting…