Skip to content

← Actionable
High, CVSS 7.5amended

node-tkinter is malware

CVE-2017-16062GHSA-mwcv-m549-5cm8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-tkinter 1.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2017-16062: 1.07% estimated exploitation activity in the next 30 days; percentile 64.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The node-tkinter package is a piece of malware that steals environment variables and sends them to attacker controlled locations. All versions have been unpublished from the npm registry. Recommendation As this package is malware, if you find it installed in your environment, the real security concern is determining how it got there. If you have found this installed in your environment, you should: 1. Delete the package 2. Clear your npm cache 3. Ensure it is not present in any other package.json files on your system 4. Regenerate your registry credentials, tokens, and any other sensitive credentials that may have been present in your environment variables. Additionally, any service which may have been exposed via credentials in your environment variables, such as a database, should be reviewed for indicators of compromise as well.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mwcv-m549-5cm8

  2. Revision 1 · created ·

    Published from osv record GHSA-mwcv-m549-5cm8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-16062

Advisory: node-tkinter is malware
IDs: CVE-2017-16062, GHSA-mwcv-m549-5cm8
Record: https://patchnext.com/advisories/cve-2017-16062 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node-tkinter 1.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm node-tkinter: affected <= 1.0.2; fixed in 1.0.3

## Suggested inspection (read-only)
- `npm ls node-tkinter --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node-tkinter.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mwcv-m549-5cm8 (OSV record GHSA-mwcv-m549-5cm8 lists affected ranges: npm node-tkinter >=0 <1.0.3 (fixed))
- Verified: https://github.com/advisories/GHSA-mwcv-m549-5cm8 (GitHub-reviewed advisory GHSA-mwcv-m549-5cm8 lists affected ranges: npm node-tkinter >=0 <=1.0.2)

Commands are suggestions: review each one before running it.

Loading voting…