Directory Traversal in f2e-server
CVE-2017-16038GHSA-g7j3-p357-cw8p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (f2e-server 1.12.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm f2e-server
- Affected
- <= 1.12.11
- Fixed in
- 1.12.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g7j3-p357-cw8p lists affected ranges: npm f2e-server >=0 <1.12.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g7j3-p357-cw8p lists affected ranges: npm f2e-server >=0 <=1.12.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2017-16038: 2.50% estimated exploitation activity in the next 30 days; percentile 84.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of f2e-server resolve relative file paths, resulting in a directory traversal vulnerability. A malicious actor can use this vulnerability to access files outside of the intended directory root, which may result in the disclosure of private files on the vulnerable system. Example request: Recommendation Update to version 1.12.12 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g7j3-p357-cw8p
- Revision 1 · created ·
Published from osv record GHSA-g7j3-p357-cw8p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-16038 Advisory: Directory Traversal in f2e-server IDs: CVE-2017-16038, GHSA-g7j3-p357-cw8p Record: https://patchnext.com/advisories/cve-2017-16038 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: f2e-server 1.12.12. A vendor fix does not mean a deployment is fixed. ## Affected components - npm f2e-server: affected <= 1.12.11; fixed in 1.12.12 ## Suggested inspection (read-only) - `npm ls f2e-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on f2e-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g7j3-p357-cw8p (OSV record GHSA-g7j3-p357-cw8p lists affected ranges: npm f2e-server >=0 <1.12.12 (fixed)) - Verified: https://github.com/advisories/GHSA-g7j3-p357-cw8p (GitHub-reviewed advisory GHSA-g7j3-p357-cw8p lists affected ranges: npm f2e-server >=0 <=1.12.11) Commands are suggestions: review each one before running it.
Loading voting…