Skip to content

← Actionable
Medium, CVSS 5.9

Remote Memory Exposure in request

CVE-2017-16026GHSA-7xfp-9c55-5vqj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (request 2.68.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm request

    Affected
    >= 2.49.0, < 2.68.0>= 2.2.6, < 2.68.0
    Fixed in
    2.68.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2017-16026: 2.56% estimated exploitation activity in the next 30 days; percentile 85.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of `request` will disclose local system memory to remote systems in certain circumstances. When a multipart request is made, and the type of `body` is `number`, then a buffer of that size will be allocated and sent to the remote server as the body.

Proof of Concept ```js var request = require('request'); var http = require('http'); var serveFunction = function (req, res){ req.on('data', function (data) { console.log(data) }); res.end(); }; var server = http.createServer(serveFunction); server.listen(8000); request({ method: "POST", uri: 'http://localhost:8000', multipart: [{body:500}] },function(err,res,body){}); ```

Recommendation Update to version 2.68.0 or later

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record GHSA-7xfp-9c55-5vqj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-16026

Advisory: Remote Memory Exposure in request
IDs: CVE-2017-16026, GHSA-7xfp-9c55-5vqj
Record: https://patchnext.com/advisories/cve-2017-16026 (revision 1, source checked 24 Oct 2026, 04:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: request 2.68.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm request: affected >= 2.49.0, < 2.68.0; >= 2.2.6, < 2.68.0; fixed in 2.68.0

## Suggested inspection (read-only)
- `npm ls request --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on request.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7xfp-9c55-5vqj (OSV record GHSA-7xfp-9c55-5vqj lists affected ranges: npm request >=2.49.0 =2.2.6 <2.68.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…