Denial of Service in nes
CVE-2017-16025GHSA-3pwh-5mmc-mwrx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nes 6.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nes
- Affected
- <= 6.4.0
- Fixed in
- 6.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3pwh-5mmc-mwrx lists affected ranges: npm nes >=0 <6.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3pwh-5mmc-mwrx lists affected ranges: npm nes >=0 <=6.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2017-16025: 1.87% estimated exploitation activity in the next 30 days; percentile 79.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of nes are vulnerable to denial of service when given an invalid cookie header, and websocket authentication is set to cookie. Submitting an invalid cookie on the websocket upgrade request will cause the node process to throw and exit. Recommendation Update to version 6.4.1 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3pwh-5mmc-mwrx
- Revision 1 · created ·
Published from osv record GHSA-3pwh-5mmc-mwrx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-16025 Advisory: Denial of Service in nes IDs: CVE-2017-16025, GHSA-3pwh-5mmc-mwrx Record: https://patchnext.com/advisories/cve-2017-16025 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nes 6.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nes: affected <= 6.4.0; fixed in 6.4.1 ## Suggested inspection (read-only) - `npm ls nes --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nes. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3pwh-5mmc-mwrx (OSV record GHSA-3pwh-5mmc-mwrx lists affected ranges: npm nes >=0 <6.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-3pwh-5mmc-mwrx (GitHub-reviewed advisory GHSA-3pwh-5mmc-mwrx lists affected ranges: npm nes >=0 <=6.4.0) Commands are suggestions: review each one before running it.
Loading voting…