Cross-Site Scripting in i18next
CVE-2017-16010GHSA-cmh5-qc8w-xvcq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (i18next 3.4.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm i18next
- Affected
- >= 2.0.0, < 3.4.4
- Fixed in
- 3.4.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cmh5-qc8w-xvcq lists affected ranges: npm i18next >=2.0.0 <3.4.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cmh5-qc8w-xvcq lists affected ranges: npm i18next >=2.0.0 <3.4.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2017-16010: 1.00% estimated exploitation activity in the next 30 days; percentile 62.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of i18next may fail to sanitize user input when certain configuration options are used. When using the .init method, passing interpolation options without passing an escapeValue will default to undefined rather than the assumed true. Proof of Concept When escapeValue is explicitly passed, the result of test is: This is supposed to be the default. However, if escapeValue is not included, the result is the unescaped string: Recommendation Update to version 3.4.4 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cmh5-qc8w-xvcq
- Revision 1 · created ·
Published from osv record GHSA-cmh5-qc8w-xvcq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-16010 Advisory: Cross-Site Scripting in i18next IDs: CVE-2017-16010, GHSA-cmh5-qc8w-xvcq Record: https://patchnext.com/advisories/cve-2017-16010 (revision 2, source checked 26 Oct 2026, 12:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: i18next 3.4.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm i18next: affected >= 2.0.0, < 3.4.4; fixed in 3.4.4 ## Suggested inspection (read-only) - `npm ls i18next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on i18next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cmh5-qc8w-xvcq (OSV record GHSA-cmh5-qc8w-xvcq lists affected ranges: npm i18next >=2.0.0 <3.4.4 (fixed)) - Verified: https://github.com/advisories/GHSA-cmh5-qc8w-xvcq (GitHub-reviewed advisory GHSA-cmh5-qc8w-xvcq lists affected ranges: npm i18next >=2.0.0 <3.4.4) Commands are suggestions: review each one before running it.
Loading voting…