Skip to content

← Actionable
Unratedamended

XSS in Data URI in remarkable

CVE-2017-16006GHSA-mrmf-qwxg-7c3h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (remarkable 1.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2017-16006: 0.96% estimated exploitation activity in the next 30 days; percentile 61.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of remarkable are vulnerable to cross-site scripting. Vulnerable versions of the package allow the use of data: URIs in links, and can therefore execute javascript. Proof of Concept Recommendation Update to v1.7.0 or later

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mrmf-qwxg-7c3h

  2. Revision 1 · created ·

    Published from osv record GHSA-mrmf-qwxg-7c3h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-16006

Advisory: XSS in Data URI in remarkable
IDs: CVE-2017-16006, GHSA-mrmf-qwxg-7c3h
Record: https://patchnext.com/advisories/cve-2017-16006 (revision 2, source checked 26 Oct 2026, 12:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: remarkable 1.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm remarkable: affected <= 1.6.2; fixed in 1.7.0

## Suggested inspection (read-only)
- `npm ls remarkable --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on remarkable.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mrmf-qwxg-7c3h (OSV record GHSA-mrmf-qwxg-7c3h lists affected ranges: npm remarkable >=0 <1.7.0 (fixed))
- Verified: https://github.com/advisories/GHSA-mrmf-qwxg-7c3h (GitHub-reviewed advisory GHSA-mrmf-qwxg-7c3h lists affected ranges: npm remarkable >=0 <=1.6.2)

Commands are suggestions: review each one before running it.

Loading voting…