Skip to content

← Actionable
Unrated

Node.js had a bug in versions 8.X and 9.X which caused buffers to not be initialized when the encoding for the fill value did not match the encoding specified. For example, 'Buffer.alloc(0x100…

CVE-2017-15897

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 9.2.1, 8.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • runtime node

    Affected
    >= 8.0.0, < 8.9.3>= 9.0.0, < 9.2.1
    Fixed in
    9.2.1, 8.9.3

Sources

  • raw.githubusercontent.com runtime security intelligence

    Node.js security working group core entry 45 lists CVE-2017-15897 affecting node >=8.0.0 =9.0.0 <9.2.1

    VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.

  • nodejs.org runtime security intelligence

    The nodejs.org release index dates the first patched release for CVE-2017-15897 to 2017-12-07.

    VerifiedObserved Official nodejs.org release index (dist/index.json).

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2017-15897: 2.32% estimated exploitation activity in the next 30 days; percentile 83.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Node.js had a bug in versions 8.X and 9.X which caused buffers to not be initialized when the encoding for the fill value did not match the encoding specified. For example, 'Buffer.alloc(0x100, "This is not correctly encoded", "hex");' The buffer implementation was updated such that the buffer will be initialized to all zeros in these cases.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · published ·

    Published from vendor_advisory record nodejs-security-wg:core:45

  2. Revision 1 · created ·

    Created from vendor_advisory record nodejs-security-wg:core:45

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-15897

Advisory: Node.js had a bug in versions 8.X and 9.X which caused buffers to not be initialized when the encoding for the fill value did not match the encoding specified. For example, 'Buffer.alloc(0x100…
IDs: CVE-2017-15897
Record: https://patchnext.com/advisories/cve-2017-15897 (revision 2, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node 9.2.1, 8.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- runtime node: affected >= 8.0.0, < 8.9.3; >= 9.0.0, < 9.2.1; fixed in 9.2.1, 8.9.3

## Suggested inspection (read-only)
- runtime node: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/45.json (Node.js security working group core entry 45 lists CVE-2017-15897 affecting node >=8.0.0 =9.0.0 <9.2.1)
- Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2017-15897 to 2017-12-07.)

Commands are suggestions: review each one before running it.

Loading voting…