Denial of service via deserialization attack in nifi
CVE-2017-15703GHSA-xwx6-vmj4-5rv8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.nifi:nifi-framework-cluster-protocol 1.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.nifi:nifi-framework-cluster-protocol
- Affected
- < 1.5.0
- Fixed in
- 1.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xwx6-vmj4-5rv8 lists affected ranges: Maven org.apache.nifi:nifi-framework-cluster-protocol >=0 <1.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.0 · CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H
- EPSS
- CVE-2017-15703: 0.86% estimated exploitation activity in the next 30 days; percentile 58.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability found in Apache NIFI before 1.5.0-RC1. Attacker can perform XXE attacks through JAXB.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xwx6-vmj4-5rv8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-15703 Advisory: Denial of service via deserialization attack in nifi IDs: CVE-2017-15703, GHSA-xwx6-vmj4-5rv8 Record: https://patchnext.com/advisories/cve-2017-15703 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.nifi:nifi-framework-cluster-protocol 1.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.nifi:nifi-framework-cluster-protocol: affected < 1.5.0; fixed in 1.5.0 ## Suggested inspection (read-only) - Maven org.apache.nifi:nifi-framework-cluster-protocol: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.nifi:nifi-framework-cluster-protocol. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xwx6-vmj4-5rv8 (GitHub-reviewed advisory GHSA-xwx6-vmj4-5rv8 lists affected ranges: Maven org.apache.nifi:nifi-framework-cluster-protocol >=0 <1.5.0) Commands are suggestions: review each one before running it.
Loading voting…