Apache Qpid Broker vulnerable to authentication port spoofing
CVE-2017-15702GHSA-269m-695x-j34p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.qpid:qpid-broker 6.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.qpid:qpid-broker
- Affected
- >= 0.18, <= 0.32
- Fixed in
- 6.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-269m-695x-j34p lists affected ranges: Maven org.apache.qpid:qpid-broker >=0.18 <=0.32
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-15702: 6.21% estimated exploitation activity in the next 30 days; percentile 93.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Qpid Broker-J versions 0.18 through 0.32 are vulnerable to authentication port spoofing. When the broker is configured with different authentication providers on different ports, one of which is an HTTP port, then the broker can be tricked by a remote unauthenticated attacker connecting to the HTTP port into using an authentication provider that was configured on a different port. The attacker still needs valid credentials with the authentication provider on the spoofed port. This becomes an issue when the spoofed port has weaker authentication protection (e.g., anonymous access, default accounts) and is normally protected by firewall rules or similar which can be circumvented by this vulnerability. AMQP ports are not affected.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-269m-695x-j34p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-15702 Advisory: Apache Qpid Broker vulnerable to authentication port spoofing IDs: CVE-2017-15702, GHSA-269m-695x-j34p Record: https://patchnext.com/advisories/cve-2017-15702 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.qpid:qpid-broker 6.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.qpid:qpid-broker: affected >= 0.18, <= 0.32; fixed in 6.0.0 ## Suggested inspection (read-only) - Maven org.apache.qpid:qpid-broker: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.qpid:qpid-broker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-269m-695x-j34p (GitHub-reviewed advisory GHSA-269m-695x-j34p lists affected ranges: Maven org.apache.qpid:qpid-broker >=0.18 <=0.32) Commands are suggestions: review each one before running it.
Loading voting…