Skip to content

← Actionable
Critical, CVSS 9.8

Apache NiFi XSS issue in context path handling

CVE-2017-15697GHSA-29ph-fjf3-c5cm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.nifi:nifi 1.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-15697: 4.83% estimated exploitation activity in the next 30 days; percentile 92.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A malicious X-ProxyContextPath or X-Forwarded-Context header containing external resources or embedded code could cause remote code execution. The fix to properly handle these headers was applied on the Apache NiFi 1.5.0 release. Users running a prior 1.x release should upgrade to the appropriate release.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-29ph-fjf3-c5cm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-15697

Advisory: Apache NiFi XSS issue in context path handling
IDs: CVE-2017-15697, GHSA-29ph-fjf3-c5cm
Record: https://patchnext.com/advisories/cve-2017-15697 (revision 1, source checked 26 Oct 2026, 16:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.nifi:nifi 1.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.nifi:nifi: affected >= 1.0.0, < 1.5.0; fixed in 1.5.0

## Suggested inspection (read-only)
- Maven org.apache.nifi:nifi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.nifi:nifi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-29ph-fjf3-c5cm (GitHub-reviewed advisory GHSA-29ph-fjf3-c5cm lists affected ranges: Maven org.apache.nifi:nifi >=1.0.0 <1.5.0)

Commands are suggestions: review each one before running it.

Loading voting…