Argument Injection in Apache Geode server
CVE-2017-15694GHSA-p426-qw2p-v95v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.geode:geode-core 1.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.geode:geode-core
- Affected
- < 1.9.0
- Fixed in
- 1.9.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p426-qw2p-v95v lists affected ranges: Maven org.apache.geode:geode-core >=0 <1.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2017-15694: 2.15% estimated exploitation activity in the next 30 days; percentile 82.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When an Apache Geode server versions 1.0.0 to 1.8.0 is operating in secure mode, a user with write permissions for specific data regions can modify internal cluster metadata. A malicious user could modify this data in a way that affects the operation of the cluster.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p426-qw2p-v95v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-15694 Advisory: Argument Injection in Apache Geode server IDs: CVE-2017-15694, GHSA-p426-qw2p-v95v Record: https://patchnext.com/advisories/cve-2017-15694 (revision 1, source checked 26 Oct 2026, 16:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.geode:geode-core 1.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.geode:geode-core: affected < 1.9.0; fixed in 1.9.0 ## Suggested inspection (read-only) - Maven org.apache.geode:geode-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.geode:geode-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p426-qw2p-v95v (GitHub-reviewed advisory GHSA-p426-qw2p-v95v lists affected ranges: Maven org.apache.geode:geode-core >=0 <1.9.0) Commands are suggestions: review each one before running it.
Loading voting…