Bacula-web SQL Injection Vulnerabilities
CVE-2017-15367GHSA-fv4m-5j2c-787r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bacula-web/bacula-web 8.0.0-rc2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist bacula-web/bacula-web
- Affected
- < 8.0.0-rc2
- Fixed in
- 8.0.0-rc2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fv4m-5j2c-787r lists affected ranges: Packagist bacula-web/bacula-web >=0 <8.0.0-rc2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-15367: 23.07% estimated exploitation activity in the next 30 days; percentile 97.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Bacula-web before 8.0.0-rc2 is affected by multiple SQL Injection vulnerabilities that could allow an attacker to access the Bacula database and, depending on configuration, escalate privileges on the server.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fv4m-5j2c-787r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-15367 Advisory: Bacula-web SQL Injection Vulnerabilities IDs: CVE-2017-15367, GHSA-fv4m-5j2c-787r Record: https://patchnext.com/advisories/cve-2017-15367 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bacula-web/bacula-web 8.0.0-rc2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist bacula-web/bacula-web: affected < 8.0.0-rc2; fixed in 8.0.0-rc2 ## Suggested inspection (read-only) - Packagist bacula-web/bacula-web: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bacula-web/bacula-web. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fv4m-5j2c-787r (GitHub-reviewed advisory GHSA-fv4m-5j2c-787r lists affected ranges: Packagist bacula-web/bacula-web >=0 <8.0.0-rc2) Commands are suggestions: review each one before running it.
Loading voting…