Skip to content

← Actionable
Medium, CVSS 5.4

OctoberCMS Cross-Site Scripting

CVE-2017-15284GHSA-gvgf-fp4m-2hw6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/rain 1.0.426), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2017-15284: 4.03% estimated exploitation activity in the next 30 days; percentile 90.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-Site Scripting exists in OctoberCMS 1.0.425 (aka Build 425), allowing a least privileged user to upload an SVG file containing malicious code as the Avatar for the profile. When this is opened by the Admin, it causes JavaScript execution in the context of the Admin account.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gvgf-fp4m-2hw6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-15284

Advisory: OctoberCMS Cross-Site Scripting
IDs: CVE-2017-15284, GHSA-gvgf-fp4m-2hw6
Record: https://patchnext.com/advisories/cve-2017-15284 (revision 1, source checked 26 Oct 2026, 14:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: october/rain 1.0.426. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist october/rain: affected < 1.0.426; fixed in 1.0.426

## Suggested inspection (read-only)
- Packagist october/rain: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on october/rain.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gvgf-fp4m-2hw6 (GitHub-reviewed advisory GHSA-gvgf-fp4m-2hw6 lists affected ranges: Packagist october/rain >=0 <1.0.426)

Commands are suggestions: review each one before running it.

Loading voting…