Skip to content

← Actionable
Critical, CVSS 9.8

jackson-databind vulnerable to deserialization flaw leading to unauthenticated remote code execution

CVE-2017-15095GHSA-h592-38cm-4ggp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.fasterxml.jackson.core:jackson-databind 2.9.4, 2.8.11, 2.7.9.2, 2.6.7.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-h592-38cm-4ggp lists affected ranges: Maven com.fasterxml.jackson.core:jackson-databind >=2.9.0 =2.8.0 =2.0.0 =2.7.0 <2.7.9.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-15095: 8.36% estimated exploitation activity in the next 30 days; percentile 94.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

jackson-databind in versions prior to 2.8.11 and 2.9.4 contain a deserialization flaw which allows an unauthenticated user to perform code execution by sending maliciously crafted input to the readValue method of the ObjectMapper. This issue extends the previous flaw CVE-2017-7525, blacklisting additonal vulnerable classes.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h592-38cm-4ggp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-15095

Advisory: jackson-databind vulnerable to deserialization flaw leading to unauthenticated remote code execution
IDs: CVE-2017-15095, GHSA-h592-38cm-4ggp
Record: https://patchnext.com/advisories/cve-2017-15095 (revision 1, source checked 26 Oct 2026, 16:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.fasterxml.jackson.core:jackson-databind 2.9.4, 2.8.11, 2.7.9.2, 2.6.7.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.fasterxml.jackson.core:jackson-databind: affected >= 2.9.0, < 2.9.4; >= 2.8.0, < 2.8.11; >= 2.0.0, < 2.6.7.3; >= 2.7.0, < 2.7.9.2; fixed in 2.9.4, 2.7.9.2, 2.6.7.3, 2.8.11

## Suggested inspection (read-only)
- Maven com.fasterxml.jackson.core:jackson-databind: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.fasterxml.jackson.core:jackson-databind.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h592-38cm-4ggp (GitHub-reviewed advisory GHSA-h592-38cm-4ggp lists affected ranges: Maven com.fasterxml.jackson.core:jackson-databind >=2.9.0 =2.8.0 =2.0.0 =2.7.0 <2.7.9.2)

Commands are suggestions: review each one before running it.

Loading voting…