Skip to content

← Actionable
Medium, CVSS 5.4

TeamPass stored cross-site scripting (XSS) vulnerability

CVE-2017-15051GHSA-r68m-4v39-cf43

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nilsteampassnet/teampass 2.1.27.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2017-15051: 0.95% estimated exploitation activity in the next 30 days; percentile 61.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Multiple stored cross-site scripting (XSS) vulnerabilities in TeamPass before 2.1.27.9 allow authenticated remote attackers to inject arbitrary web script or HTML via the (1) URL value of an item or (2) user log history. To exploit the vulnerability, the attacker must be first authenticated to the application. For the first one, the attacker has to simply inject XSS code within the URL field of a shared item. For the second one however, the attacker must prepare a payload within its profile, and then ask an administrator to modify its profile. From there, whenever the administrator accesses the log, it can be XSS'ed.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r68m-4v39-cf43

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-15051

Advisory: TeamPass stored cross-site scripting (XSS) vulnerability
IDs: CVE-2017-15051, GHSA-r68m-4v39-cf43
Record: https://patchnext.com/advisories/cve-2017-15051 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nilsteampassnet/teampass 2.1.27.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist nilsteampassnet/teampass: affected < 2.1.27.9; fixed in 2.1.27.9

## Suggested inspection (read-only)
- Packagist nilsteampassnet/teampass: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nilsteampassnet/teampass.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r68m-4v39-cf43 (GitHub-reviewed advisory GHSA-r68m-4v39-cf43 lists affected ranges: Packagist nilsteampassnet/teampass >=0 <2.1.27.9)

Commands are suggestions: review each one before running it.

Loading voting…