Regular Expression Denial of Service in tough-cookie
CVE-2017-15010GHSA-g7q5-pjjr-gqvp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tough-cookie 2.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm tough-cookie
- Affected
- < 2.3.3
- Fixed in
- 2.3.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g7q5-pjjr-gqvp lists affected ranges: npm tough-cookie >=0 <2.3.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g7q5-pjjr-gqvp lists affected ranges: npm tough-cookie >=0 <2.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2017-15010: 3.28% estimated exploitation activity in the next 30 days; percentile 88.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of tough-cookie are susceptible to a regular expression denial of service. The amplification on this vulnerability is relatively low - it takes around 2 seconds for the engine to execute on a malicious input which is 50,000 characters in length. If node was compiled using the -DHTTPMAXHEADERSIZE however, the impact of the vulnerability can be significant, as the primary limitation for the vulnerability is the default max HTTP header length in node. Recommendation Update to version 2.3.3 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g7q5-pjjr-gqvp
- Revision 1 · created ·
Published from osv record GHSA-g7q5-pjjr-gqvp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-15010 Advisory: Regular Expression Denial of Service in tough-cookie IDs: CVE-2017-15010, GHSA-g7q5-pjjr-gqvp Record: https://patchnext.com/advisories/cve-2017-15010 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tough-cookie 2.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm tough-cookie: affected < 2.3.3; fixed in 2.3.3 ## Suggested inspection (read-only) - `npm ls tough-cookie --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tough-cookie. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g7q5-pjjr-gqvp (OSV record GHSA-g7q5-pjjr-gqvp lists affected ranges: npm tough-cookie >=0 <2.3.3 (fixed)) - Verified: https://github.com/advisories/GHSA-g7q5-pjjr-gqvp (GitHub-reviewed advisory GHSA-g7q5-pjjr-gqvp lists affected ranges: npm tough-cookie >=0 <2.3.3) Commands are suggestions: review each one before running it.
Loading voting…