Skip to content

← Actionable
High, CVSS 8.8

Gem in a Box vulnerable to Cross-site Request Forgery

CVE-2017-14683GHSA-qwv2-2x8g-g43g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (geminabox 0.13.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems geminabox

    Affected
    < 0.13.7
    Fixed in
    0.13.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-14683: 0.50% estimated exploitation activity in the next 30 days; percentile 42.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

geminabox (aka Gem in a Box) before 0.13.7 has CSRF, as demonstrated by an unintended gem upload.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qwv2-2x8g-g43g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-14683

Advisory: Gem in a Box vulnerable to Cross-site Request Forgery
IDs: CVE-2017-14683, GHSA-qwv2-2x8g-g43g
Record: https://patchnext.com/advisories/cve-2017-14683 (revision 1, source checked 26 Oct 2026, 15:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: geminabox 0.13.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems geminabox: affected < 0.13.7; fixed in 0.13.7

## Suggested inspection (read-only)
- RubyGems geminabox: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on geminabox.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qwv2-2x8g-g43g (GitHub-reviewed advisory GHSA-qwv2-2x8g-g43g lists affected ranges: RubyGems geminabox >=0 <0.13.7)

Commands are suggestions: review each one before running it.

Loading voting…