Skip to content

← Actionable
High, CVSS 8.1

Access Restriction Bypass in go-ldap

CVE-2017-14623GHSA-x27w-qxhg-343v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/go-ldap/ldap 2.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-14623: 1.69% estimated exploitation activity in the next 30 days; percentile 77.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In the ldap.v2 (aka go-ldap) package through 2.5.0 for Go, an attacker may be able to login with an empty password. This issue affects an application using this package if these conditions are met: (1) it relies only on the return error of the Bind function call to determine whether a user is authorized (i.e., a nil return value is interpreted as successful authorization) and (2) it is used with an LDAP server allowing unauthenticated bind.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x27w-qxhg-343v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-14623

Advisory: Access Restriction Bypass in go-ldap
IDs: CVE-2017-14623, GHSA-x27w-qxhg-343v
Record: https://patchnext.com/advisories/cve-2017-14623 (revision 1, source checked 26 Oct 2026, 15:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/go-ldap/ldap 2.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/go-ldap/ldap: affected < 2.5.0; fixed in 2.5.0

## Suggested inspection (read-only)
- Go github.com/go-ldap/ldap: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/go-ldap/ldap.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x27w-qxhg-343v (GitHub-reviewed advisory GHSA-x27w-qxhg-343v lists affected ranges: Go github.com/go-ldap/ldap >=0 <2.5.0)

Commands are suggestions: review each one before running it.

Loading voting…