Improper Verification of Cryptographic Signature in Nimbus JOSE+JWT
CVE-2017-12974GHSA-pfv2-37f7-9m6w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.nimbusds:nimbus-jose-jwt 4.36), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.nimbusds:nimbus-jose-jwt
- Affected
- < 4.36
- Fixed in
- 4.36
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pfv2-37f7-9m6w lists affected ranges: Maven com.nimbusds:nimbus-jose-jwt >=0 <4.36
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2017-12974: 1.26% estimated exploitation activity in the next 30 days; percentile 69.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Nimbus JOSE+JWT before 4.36 proceeds with ECKey construction without ensuring that the public x and y coordinates are on the specified curve, which allows attackers to conduct an Invalid Curve Attack in environments where the JCE provider lacks the applicable curve validation.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pfv2-37f7-9m6w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-12974 Advisory: Improper Verification of Cryptographic Signature in Nimbus JOSE+JWT IDs: CVE-2017-12974, GHSA-pfv2-37f7-9m6w Record: https://patchnext.com/advisories/cve-2017-12974 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.nimbusds:nimbus-jose-jwt 4.36. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.nimbusds:nimbus-jose-jwt: affected < 4.36; fixed in 4.36 ## Suggested inspection (read-only) - Maven com.nimbusds:nimbus-jose-jwt: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.nimbusds:nimbus-jose-jwt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pfv2-37f7-9m6w (GitHub-reviewed advisory GHSA-pfv2-37f7-9m6w lists affected ranges: Maven com.nimbusds:nimbus-jose-jwt >=0 <4.36) Commands are suggestions: review each one before running it.
Loading voting…