Incorrect persistent NameID generation in SimpleSAMLphp
CVE-2017-12873GHSA-gp2m-7cfp-h6gf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (simplesamlphp/simplesamlphp 1.14.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist simplesamlphp/simplesamlphp
- Affected
- >= 1.7.0, < 1.14.11
- Fixed in
- 1.14.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gp2m-7cfp-h6gf lists affected ranges: Packagist simplesamlphp/simplesamlphp >=1.7.0 <1.14.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-12873: 1.66% estimated exploitation activity in the next 30 days; percentile 76.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Background When a SimpleSAMLphp Identity Provider is misconfigured, a bug in the software when trying to build a persistent NameID to univocally identify the authenticating subject could cause different users to get the same identifier generated, depending on the attributes available for them right after authentication. Please note that even though this is possible thanks to a bug, an IdP must be misconfigured to release persistent NameIDs even if it is not properly configured to generate them based on the specifics of the deployment. Description Persistent NameIDs will typically be sent as part of the Subject element of a SAML assertion, or as the contents of the eduPersonTargetedID attribute. Here is an example of such a NameID: <NameID Format=“urn:oasis:names:tc:SAML:2.0:nameid-format:persistent“ zbonsm0Yn9Gnw14uQEEPr6AO7d+IvxwCQN3t+o24jYs= </NameID Some service providers will use this information to identify a user across sessions because a persistent NameID will never change for…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gp2m-7cfp-h6gf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-12873 Advisory: Incorrect persistent NameID generation in SimpleSAMLphp IDs: CVE-2017-12873, GHSA-gp2m-7cfp-h6gf Record: https://patchnext.com/advisories/cve-2017-12873 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: simplesamlphp/simplesamlphp 1.14.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist simplesamlphp/simplesamlphp: affected >= 1.7.0, < 1.14.11; fixed in 1.14.11 ## Suggested inspection (read-only) - Packagist simplesamlphp/simplesamlphp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on simplesamlphp/simplesamlphp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gp2m-7cfp-h6gf (GitHub-reviewed advisory GHSA-gp2m-7cfp-h6gf lists affected ranges: Packagist simplesamlphp/simplesamlphp >=1.7.0 <1.14.11) Commands are suggestions: review each one before running it.
Loading voting…