Denial of Service in Apache POI
CVE-2017-12626GHSA-523c-xh4g-mh5m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.poi:poi 3.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.poi:poi
- Affected
- < 3.17
- Fixed in
- 3.17
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-523c-xh4g-mh5m lists affected ranges: Maven org.apache.poi:poi >=0 <3.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2017-12626: 10.14% estimated exploitation activity in the next 30 days; percentile 95.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache POI in versions prior to release 3.17 are vulnerable to Denial of Service Attacks: - Infinite Loops while parsing crafted WMF, EMF, MSG and macros (POI bugs 61338 and 61294) - Out of Memory Exceptions while parsing crafted DOC, PPT and XLS (POI bugs 52372 and 61295)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-523c-xh4g-mh5m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-12626 Advisory: Denial of Service in Apache POI IDs: CVE-2017-12626, GHSA-523c-xh4g-mh5m Record: https://patchnext.com/advisories/cve-2017-12626 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.poi:poi 3.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.poi:poi: affected < 3.17; fixed in 3.17 ## Suggested inspection (read-only) - Maven org.apache.poi:poi: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.poi:poi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-523c-xh4g-mh5m (GitHub-reviewed advisory GHSA-523c-xh4g-mh5m lists affected ranges: Maven org.apache.poi:poi >=0 <3.17) Commands are suggestions: review each one before running it.
Loading voting…