Skip to content

← Actionable
High, CVSS 8.1Exploited · CISA KEV

Unrestricted Upload of File with Dangerous Type Apache Tomcat

CVE-2017-12617GHSA-xjgh-84hx-56c5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-catalina 9.0.1, 8.5.23, 8.0.47, 7.0.82; org.apache.tomcat.embed:tomcat-embed-core 9.0.1, 8.5.23, 8.0.47, 7.0.82), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-xjgh-84hx-56c5 lists affected ranges: Maven org.apache.tomcat:tomcat-catalina >=9.0.0.M1 =8.5.0 =8.0.0-RC1 =7.0.0 =9.0.0.M1 =8.5.0 =8.0.0-RC1 =7.0.0 <=7.0.81

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

  • CISA Known Exploited Vulnerabilities Catalog

    CISA added CVE-2017-12617 to the Known Exploited Vulnerabilities catalog on 2022-03-25.

    VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2022-03-25).

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
EPSS
  • CVE-2017-12617: 99.97% estimated exploitation activity in the next 30 days; percentile 99.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When running Apache Tomcat versions 9.0.0.M1 to 9.0.0, 8.5.0 to 8.5.22, 8.0.0.RC1 to 8.0.46 and 7.0.0 to 7.0.81 with HTTP PUTs enabled (e.g. via setting the readonly initialisation parameter of the Default servlet to false) it was possible to upload a JSP file to the server via a specially crafted request. This JSP could then be requested and any code it contained would be executed by the server.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xjgh-84hx-56c5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-12617

Advisory: Unrestricted Upload of File with Dangerous Type Apache Tomcat
IDs: CVE-2017-12617, GHSA-xjgh-84hx-56c5
Record: https://patchnext.com/advisories/cve-2017-12617 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-catalina 9.0.1, 8.5.23, 8.0.47, 7.0.82; org.apache.tomcat.embed:tomcat-embed-core 9.0.1, 8.5.23, 8.0.47, 7.0.82. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-catalina: affected >= 9.0.0.M1, <= 9.0.0M27; >= 8.5.0, <= 8.5.22; >= 8.0.0-RC1, <= 8.0.46; >= 7.0.0, <= 7.0.81; fixed in 8.0.47, 9.0.1, 8.5.23, 7.0.82
- Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 9.0.0.M1, <= 9.0.0M27; >= 8.5.0, <= 8.5.22; >= 8.0.0-RC1, <= 8.0.46; >= 7.0.0, <= 7.0.81; fixed in 8.0.47, 9.0.1, 8.5.23, 7.0.82

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-catalina: check the installed version with your package manager.
- Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xjgh-84hx-56c5 (GitHub-reviewed advisory GHSA-xjgh-84hx-56c5 lists affected ranges: Maven org.apache.tomcat:tomcat-catalina >=9.0.0.M1 =8.5.0 =8.0.0-RC1 =7.0.0 =9.0.0.M1 =8.5.0 =8.0.0-RC1 =7.0.0 <=7.0.81)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2017-12617 to the Known Exploited Vulnerabilities catalog on 2022-03-25.)

Commands are suggestions: review each one before running it.

Loading voting…