Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat
CVE-2017-12616GHSA-8qq4-8jvq-mfw4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat-catalina 7.0.81), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-catalina
- Affected
- >= 7.0.0, <= 7.0.80
- Fixed in
- 7.0.81
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8qq4-8jvq-mfw4 lists affected ranges: Maven org.apache.tomcat:tomcat-catalina >=7.0.0 <=7.0.80
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2017-12616: 70.12% estimated exploitation activity in the next 30 days; percentile 99.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When using a VirtualDirContext with Apache Tomcat 7.0.0 to 7.0.80 it was possible to bypass security constraints and/or view the source code of JSPs for resources served by the VirtualDirContext using a specially crafted request.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8qq4-8jvq-mfw4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-12616 Advisory: Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat IDs: CVE-2017-12616, GHSA-8qq4-8jvq-mfw4 Record: https://patchnext.com/advisories/cve-2017-12616 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat-catalina 7.0.81. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-catalina: affected >= 7.0.0, <= 7.0.80; fixed in 7.0.81 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-catalina: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-catalina. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8qq4-8jvq-mfw4 (GitHub-reviewed advisory GHSA-8qq4-8jvq-mfw4 lists affected ranges: Maven org.apache.tomcat:tomcat-catalina >=7.0.0 <=7.0.80) Commands are suggestions: review each one before running it.
Loading voting…