Out-of-bounds Write in OpenCV
CVE-2017-12604GHSA-c7gp-2pch-qh2v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (opencv-python 3.3.1.11; opencv-contrib-python 3.3.1.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI opencv-python
- Affected
- <= 3.3.0.9
- Fixed in
- 3.3.1.11
- Affected
- <= 3.3.0.9
- Fixed in
- 3.3.1.11
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c7gp-2pch-qh2v lists affected ranges: PyPI opencv-python >=0 =0 <3.3.1.11 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c7gp-2pch-qh2v lists affected ranges: PyPI opencv-python >=0 =0 <=3.3.0.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-12604: 1.99% estimated exploitation activity in the next 30 days; percentile 80.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
OpenCV (Open Source Computer Vision Library) through 3.3 (corresponding to OpenCV-Python and OpenCV-Contrib-Python 3.3.0.9) has an out-of-bounds write error in the FillUniColor function in utils.cpp when reading an image file by using cv::imread.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c7gp-2pch-qh2v
- Revision 1 · created ·
Published from osv record GHSA-c7gp-2pch-qh2v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-12604 Advisory: Out-of-bounds Write in OpenCV IDs: CVE-2017-12604, GHSA-c7gp-2pch-qh2v Record: https://patchnext.com/advisories/cve-2017-12604 (revision 2, source checked 26 Oct 2026, 13:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: opencv-python 3.3.1.11; opencv-contrib-python 3.3.1.11. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI opencv-python: affected <= 3.3.0.9; fixed in 3.3.1.11 - PyPI opencv-contrib-python: affected <= 3.3.0.9; fixed in 3.3.1.11 ## Suggested inspection (read-only) - `python -m pip show opencv-python`: prints the installed version. Run with the environment that serves production active. - `python -m pip show opencv-contrib-python`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on opencv-python, opencv-contrib-python. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c7gp-2pch-qh2v (OSV record GHSA-c7gp-2pch-qh2v lists affected ranges: PyPI opencv-python >=0 =0 <3.3.1.11 (fixed)) - Verified: https://github.com/advisories/GHSA-c7gp-2pch-qh2v (GitHub-reviewed advisory GHSA-c7gp-2pch-qh2v lists affected ranges: PyPI opencv-python >=0 =0 <=3.3.0.9) Commands are suggestions: review each one before running it.
Loading voting…