Electron vulnerable to remote command execution
CVE-2017-12581GHSA-7fv9-m79r-j9x8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 1.6.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm electron
- Affected
- < 1.6.8
- Fixed in
- 1.6.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7fv9-m79r-j9x8 lists affected ranges: npm electron >=0 <1.6.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7fv9-m79r-j9x8 lists affected ranges: npm electron >=0 <1.6.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-12581: 6.69% estimated exploitation activity in the next 30 days; percentile 93.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Electron before 1.6.8 allows remote command execution because of a nodeIntegration bypass vulnerability. This also affects all applications that bundle Electron code equivalent to 1.6.8 or earlier. Bypassing the Same Origin Policy (SOP) is a precondition; however, recent Electron versions do not have strict SOP enforcement. Combining an SOP bypass with a privileged URL internally used by Electron, it was possible to execute native Node.js primitives in order to run OS commands on the user's host. Specifically, a chrome-devtools://devtools/bundled/inspector.html window could be used to eval a Node.js childprocess.execFile API call.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7fv9-m79r-j9x8
- Revision 1 · created ·
Published from osv record GHSA-7fv9-m79r-j9x8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-12581 Advisory: Electron vulnerable to remote command execution IDs: CVE-2017-12581, GHSA-7fv9-m79r-j9x8 Record: https://patchnext.com/advisories/cve-2017-12581 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: electron 1.6.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm electron: affected < 1.6.8; fixed in 1.6.8 ## Suggested inspection (read-only) - `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on electron. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7fv9-m79r-j9x8 (OSV record GHSA-7fv9-m79r-j9x8 lists affected ranges: npm electron >=0 <1.6.8 (fixed)) - Verified: https://github.com/advisories/GHSA-7fv9-m79r-j9x8 (GitHub-reviewed advisory GHSA-7fv9-m79r-j9x8 lists affected ranges: npm electron >=0 <1.6.8) Commands are suggestions: review each one before running it.
Loading voting…