Openstack tripleo-heat-templates unauthenticated file access
CVE-2017-12155GHSA-w8gx-hhcx-px6w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tripleo-heat-templates 7.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 7.0.6
- Fixed in
- 7.0.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w8gx-hhcx-px6w lists affected ranges: PyPI tripleo-heat-templates >=0 <7.0.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w8gx-hhcx-px6w lists affected ranges: PyPI tripleo-heat-templates >=0 <7.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2017-12155: 0.29% estimated exploitation activity in the next 30 days; percentile 21.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A resource-permission flaw was found in the tripleo-heat-templates package where ceph.client.openstack.keyring is created as world-readable. A local attacker with access to the key could read or modify data on Ceph cluster pools for OpenStack as though the attacker were the OpenStack service, thus potentially reading or modifying data in an OpenStack Block Storage volume. This has been patched in versions 7.0.6 and 8.0.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w8gx-hhcx-px6w
- Revision 1 · created ·
Published from osv record GHSA-w8gx-hhcx-px6w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-12155 Advisory: Openstack tripleo-heat-templates unauthenticated file access IDs: CVE-2017-12155, GHSA-w8gx-hhcx-px6w Record: https://patchnext.com/advisories/cve-2017-12155 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tripleo-heat-templates 7.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tripleo-heat-templates: affected < 7.0.6; fixed in 7.0.6 ## Suggested inspection (read-only) - `python -m pip show tripleo-heat-templates`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tripleo-heat-templates. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w8gx-hhcx-px6w (OSV record GHSA-w8gx-hhcx-px6w lists affected ranges: PyPI tripleo-heat-templates >=0 <7.0.6 (fixed)) - Verified: https://github.com/advisories/GHSA-w8gx-hhcx-px6w (GitHub-reviewed advisory GHSA-w8gx-hhcx-px6w lists affected ranges: PyPI tripleo-heat-templates >=0 <7.0.6) Commands are suggestions: review each one before running it.
Loading voting…