rails_admin ruby gem XSS
CVE-2017-12098GHSA-pxr8-w3jq-rcwj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rails_admin 1.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rails_admin
- Affected
- < 1.3.0
- Fixed in
- 1.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pxr8-w3jq-rcwj lists affected ranges: RubyGems rails_admin >=0 <1.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2017-12098: 1.28% estimated exploitation activity in the next 30 days; percentile 70.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An exploitable cross site scripting (XSS) vulnerability exists in the add filter functionality of the railsadmin rails gem version 1.2.0. A specially crafted URL can cause an XSS flaw resulting in an attacker being able to execute arbitrary javascript on the victim's browser. An attacker can phish an authenticated user to trigger this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pxr8-w3jq-rcwj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-12098 Advisory: rails_admin ruby gem XSS IDs: CVE-2017-12098, GHSA-pxr8-w3jq-rcwj Record: https://patchnext.com/advisories/cve-2017-12098 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rails_admin 1.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rails_admin: affected < 1.3.0; fixed in 1.3.0 ## Suggested inspection (read-only) - RubyGems rails_admin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rails_admin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pxr8-w3jq-rcwj (GitHub-reviewed advisory GHSA-pxr8-w3jq-rcwj lists affected ranges: RubyGems rails_admin >=0 <1.3.0) Commands are suggestions: review each one before running it.
Loading voting…