Authentication bypass via incorrect XML canonicalization and DOM traversal in saml2-js
CVE-2017-11429GHSA-5p5w-j3g7-w4wv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (saml2-js 2.0.2, 1.12.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm saml2-js
- Affected
- < 1.12.4>= 2.0.0, < 2.0.2
- Fixed in
- 1.12.4, 2.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5p5w-j3g7-w4wv lists affected ranges: npm saml2-js >=0 =2.0.0 <2.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5p5w-j3g7-w4wv lists affected ranges: npm saml2-js >=0 =2.0.0 <2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2017-11429: 2.74% estimated exploitation activity in the next 30 days; percentile 86.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of saml2-js prior to 1.12.4 or 2.0.2 are vulnerable to authentication bypass. The saml2-js library may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers. Security Assertion Markup Language (SAML) is an XML-based markup language for security assertions regarding authentication and permissions, most commonly used for single sign-on (SSO) services. Some XML DOM traversal and canonicalization APIs may be inconsistent in handling of comments within XML nodes. Incorrect use of these APIs by some SAML libraries results in incorrect parsing of the inner text of XML nodes such that any inner text after the comment is lost prior to cryptographically signing the SAML message. Text after the comment therefore has no impact on the signature on the SAML…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5p5w-j3g7-w4wv
- Revision 1 · created ·
Published from osv record GHSA-5p5w-j3g7-w4wv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-11429 Advisory: Authentication bypass via incorrect XML canonicalization and DOM traversal in saml2-js IDs: CVE-2017-11429, GHSA-5p5w-j3g7-w4wv Record: https://patchnext.com/advisories/cve-2017-11429 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: saml2-js 2.0.2, 1.12.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm saml2-js: affected < 1.12.4; >= 2.0.0, < 2.0.2; fixed in 1.12.4, 2.0.2 ## Suggested inspection (read-only) - `npm ls saml2-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on saml2-js. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5p5w-j3g7-w4wv (OSV record GHSA-5p5w-j3g7-w4wv lists affected ranges: npm saml2-js >=0 =2.0.0 <2.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-5p5w-j3g7-w4wv (GitHub-reviewed advisory GHSA-5p5w-j3g7-w4wv lists affected ranges: npm saml2-js >=0 =2.0.0 <2.0.2) Commands are suggestions: review each one before running it.
Loading voting…