Skip to content

← Actionable
Critical, CVSS 9.8

Symfony Incorrect Access Control

CVE-2017-11365GHSA-q87v-q8fw-gmj5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 3.3.5, 3.2.12, 2.8.25, 2.7.32; symfony/security-core 3.3.5, 3.2.12, 2.8.25, 2.7.32; symfony/security 3.3.5, 3.2.12, 2.8.25, 2.7.32), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/symfony

    Affected
    >= 2.7.30, < 2.7.32>= 2.8.23, < 2.8.25>= 3.2.10, < 3.2.12>= 3.3.3, < 3.3.5
    Fixed in
    2.7.32, 3.2.12, 3.3.5, 2.8.25
  • Packagist symfony/security-core

    Affected
    >= 2.7.30, < 2.7.32>= 2.8.23, < 2.8.25>= 3.2.10, < 3.2.12>= 3.3.3, < 3.3.5
    Fixed in
    2.7.32, 3.2.12, 3.3.5, 2.8.25
  • Packagist symfony/security

    Affected
    >= 2.7.30, < 2.7.32>= 2.8.23, < 2.8.25>= 3.2.10, < 3.2.12>= 3.3.3, < 3.3.5
    Fixed in
    2.7.32, 3.2.12, 3.3.5, 2.8.25

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-q87v-q8fw-gmj5 lists affected ranges: Packagist symfony/security-core >=2.7.30 =2.8.23 =3.2.10 =3.3.3 =2.7.30 =2.8.23 =3.2.10 =3.3.3 =2.7.30 =2.8.23 =3.2.10 =3.3.3 <3.3.5

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-11365: 1.85% estimated exploitation activity in the next 30 days; percentile 79.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Certain Symfony products are affected by: Incorrect Access Control. This affects Symfony 2.7.30 and Symfony 2.8.23 and Symfony 3.2.10 and Symfony 3.3.3. The type of exploitation is: remote. The component is: Password validator.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q87v-q8fw-gmj5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-11365

Advisory: Symfony Incorrect Access Control
IDs: CVE-2017-11365, GHSA-q87v-q8fw-gmj5
Record: https://patchnext.com/advisories/cve-2017-11365 (revision 1, source checked 26 Oct 2026, 14:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 3.3.5, 3.2.12, 2.8.25, 2.7.32; symfony/security-core 3.3.5, 3.2.12, 2.8.25, 2.7.32; symfony/security 3.3.5, 3.2.12, 2.8.25, 2.7.32. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected >= 2.7.30, < 2.7.32; >= 2.8.23, < 2.8.25; >= 3.2.10, < 3.2.12; >= 3.3.3, < 3.3.5; fixed in 2.7.32, 3.2.12, 3.3.5, 2.8.25
- Packagist symfony/security-core: affected >= 2.7.30, < 2.7.32; >= 2.8.23, < 2.8.25; >= 3.2.10, < 3.2.12; >= 3.3.3, < 3.3.5; fixed in 2.7.32, 3.2.12, 3.3.5, 2.8.25
- Packagist symfony/security: affected >= 2.7.30, < 2.7.32; >= 2.8.23, < 2.8.25; >= 3.2.10, < 3.2.12; >= 3.3.3, < 3.3.5; fixed in 2.7.32, 3.2.12, 3.3.5, 2.8.25

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/security-core: check the installed version with your package manager.
- Packagist symfony/security: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/security-core, symfony/security.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q87v-q8fw-gmj5 (GitHub-reviewed advisory GHSA-q87v-q8fw-gmj5 lists affected ranges: Packagist symfony/security-core >=2.7.30 =2.8.23 =3.2.10 =3.3.3 =2.7.30 =2.8.23 =3.2.10 =3.3.3 =2.7.30 =2.8.23 =3.2.10 =3.3.3 <3.3.5)

Commands are suggestions: review each one before running it.

Loading voting…