Skip to content

← Actionable
Medium, CVSS 6.5amended

Denial of Service in mqtt

CVE-2017-10910GHSA-h9mj-fghc-664w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mqtt 2.15.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mqtt

    Affected
    >= 2.0.0, < 2.15.0
    Fixed in
    2.15.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2017-10910: 2.26% estimated exploitation activity in the next 30 days; percentile 82.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of mqtt do not properly handle PUBLISH packets returning from the server, leading to a Denial of Service condition. The vulnerability is completely mitigated if the only connected servers are trusted, guaranteed not to be under the control of a malicious actor. Proof of Concept The following is a demonstration of how to generate the malicious packet sequence, but does not include information on handling the initial network connections and MQTT overhead. Recommendation Update to version 2.15.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h9mj-fghc-664w

  2. Revision 1 · created ·

    Published from osv record GHSA-h9mj-fghc-664w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-10910

Advisory: Denial of Service in mqtt
IDs: CVE-2017-10910, GHSA-h9mj-fghc-664w
Record: https://patchnext.com/advisories/cve-2017-10910 (revision 2, source checked 26 Oct 2026, 12:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mqtt 2.15.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mqtt: affected >= 2.0.0, < 2.15.0; fixed in 2.15.0

## Suggested inspection (read-only)
- `npm ls mqtt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mqtt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h9mj-fghc-664w (OSV record GHSA-h9mj-fghc-664w lists affected ranges: npm mqtt >=2.0.0 <2.15.0 (fixed))
- Verified: https://github.com/advisories/GHSA-h9mj-fghc-664w (GitHub-reviewed advisory GHSA-h9mj-fghc-664w lists affected ranges: npm mqtt >=2.0.0 <2.15.0)

Commands are suggestions: review each one before running it.

Loading voting…