Skip to content

← Actionable
Medium, CVSS 5.5

Tarball permission preservation in puppet

CVE-2017-10689GHSA-vw22-465p-8j5w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (puppet 5.3.4, 4.10.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems puppet

    Affected
    < 4.10.10>= 5.0.0, < 5.3.4
    Fixed in
    4.10.10, 5.3.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2017-10689: 0.36% estimated exploitation activity in the next 30 days; percentile 29.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When installing a module using the system tar, the PMT will filter filesystem permissions to a sane value. This may just be based on the user's umask. When using minitar, files are unpacked with whatever permissions are in the tarball. This is potentially unsafe, as tarballs can be easily created with weird permissions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vw22-465p-8j5w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-10689

Advisory: Tarball permission preservation in puppet
IDs: CVE-2017-10689, GHSA-vw22-465p-8j5w
Record: https://patchnext.com/advisories/cve-2017-10689 (revision 1, source checked 26 Oct 2026, 15:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: puppet 5.3.4, 4.10.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems puppet: affected < 4.10.10; >= 5.0.0, < 5.3.4; fixed in 4.10.10, 5.3.4

## Suggested inspection (read-only)
- RubyGems puppet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on puppet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vw22-465p-8j5w (GitHub-reviewed advisory GHSA-vw22-465p-8j5w lists affected ranges: RubyGems puppet >=0 =5.0.0 <5.3.4)

Commands are suggestions: review each one before running it.

Loading voting…