Kubernetes arbitrary file overwrite
CVE-2017-1002102GHSA-mm7g-f2gg-cw8g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/kubernetes 1.9.4, 1.8.9, 1.7.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.8.0, <= 1.8.8>= 1.9.0, <= 1.9.3>= 1.3.0, <= 1.7.13
- Fixed in
- 1.7.14, 1.8.9, 1.9.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mm7g-f2gg-cw8g lists affected ranges: Go k8s.io/kubernetes >=1.8.0 =1.9.0 =1.3.0 <=1.7.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.6 · CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:N
- EPSS
- CVE-2017-1002102: 1.10% estimated exploitation activity in the next 30 days; percentile 65.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Kubernetes versions 1.3.x, 1.4.x, 1.5.x, 1.6.x and prior to versions 1.7.14, 1.8.9 and 1.9.4 containers using a secret, configMap, projected or downwardAPI volume can trigger deletion of arbitrary files/directories from the nodes where they are running.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mm7g-f2gg-cw8g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-1002102 Advisory: Kubernetes arbitrary file overwrite IDs: CVE-2017-1002102, GHSA-mm7g-f2gg-cw8g Record: https://patchnext.com/advisories/cve-2017-1002102 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: k8s.io/kubernetes 1.9.4, 1.8.9, 1.7.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Go k8s.io/kubernetes: affected >= 1.8.0, <= 1.8.8; >= 1.9.0, <= 1.9.3; >= 1.3.0, <= 1.7.13; fixed in 1.7.14, 1.8.9, 1.9.4 ## Suggested inspection (read-only) - Go k8s.io/kubernetes: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on k8s.io/kubernetes. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mm7g-f2gg-cw8g (GitHub-reviewed advisory GHSA-mm7g-f2gg-cw8g lists affected ranges: Go k8s.io/kubernetes >=1.8.0 =1.9.0 =1.3.0 <=1.7.13) Commands are suggestions: review each one before running it.
Loading voting…