Skip to content

← Actionable
Critical, CVSS 9.8amended

Arbitrary Code Execution in mathjs

CVE-2017-1001003GHSA-pv8x-p9hq-j328

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mathjs 3.17.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mathjs

    Affected
    < 3.17.0
    Fixed in
    3.17.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-1001003: 1.69% estimated exploitation activity in the next 30 days; percentile 77.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

math.js before 3.17.0 had an issue where private properties such as a constructor could be replaced by using unicode characters when creating an object. Recommendation Upgrade to version 3.17.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pv8x-p9hq-j328

  2. Revision 1 · created ·

    Published from osv record GHSA-pv8x-p9hq-j328

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-1001003

Advisory: Arbitrary Code Execution in mathjs
IDs: CVE-2017-1001003, GHSA-pv8x-p9hq-j328
Record: https://patchnext.com/advisories/cve-2017-1001003 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mathjs 3.17.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mathjs: affected < 3.17.0; fixed in 3.17.0

## Suggested inspection (read-only)
- `npm ls mathjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mathjs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pv8x-p9hq-j328 (OSV record GHSA-pv8x-p9hq-j328 lists affected ranges: npm mathjs >=0 <3.17.0 (fixed))
- Verified: https://github.com/advisories/GHSA-pv8x-p9hq-j328 (GitHub-reviewed advisory GHSA-pv8x-p9hq-j328 lists affected ranges: npm mathjs >=0 <3.17.0)

Commands are suggestions: review each one before running it.

Loading voting…