Disabled users able to log in with third party SSO plugin
CVE-2017-1000489GHSA-6x98-fx9j-7c78
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 2.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mautic/core
- Affected
- >= 2.0.0, < 2.12.0
- Fixed in
- 2.12.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6x98-fx9j-7c78 lists affected ranges: Packagist mautic/core >=2.0.0 <2.12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-1000489: 1.12% estimated exploitation activity in the next 30 days; percentile 66.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Mautic versions 2.0.0 - 2.11.0 with a SSO plugin installed could allow a disabled user to still login using email address Patches Upgrade to 2.12.0 or later. Workarounds None. For more information If you have any questions or comments about this advisory: Email us at security@mautic.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6x98-fx9j-7c78
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-1000489 Advisory: Disabled users able to log in with third party SSO plugin IDs: CVE-2017-1000489, GHSA-6x98-fx9j-7c78 Record: https://patchnext.com/advisories/cve-2017-1000489 (revision 1, source checked 26 Oct 2026, 14:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mautic/core 2.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mautic/core: affected >= 2.0.0, < 2.12.0; fixed in 2.12.0 ## Suggested inspection (read-only) - Packagist mautic/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mautic/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6x98-fx9j-7c78 (GitHub-reviewed advisory GHSA-6x98-fx9j-7c78 lists affected ranges: Packagist mautic/core >=2.0.0 <2.12.0) Commands are suggestions: review each one before running it.
Loading voting…