Skip to content

← Actionable
Critical, CVSS 9.8Exploited · CISA KEV

Inadequate Encryption Strength

CVE-2017-1000486GHSA-j239-4gqg-5j54

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.primefaces:primefaces 6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-1000486: 94.10% estimated exploitation activity in the next 30 days; percentile 99.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Primetek Primefaces 5.x is vulnerable to a weak encryption flaw resulting in remote code execution

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j239-4gqg-5j54

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-1000486

Advisory: Inadequate Encryption Strength
IDs: CVE-2017-1000486, GHSA-j239-4gqg-5j54
Record: https://patchnext.com/advisories/cve-2017-1000486 (revision 1, source checked 26 Oct 2026, 16:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: org.primefaces:primefaces 6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.primefaces:primefaces: affected >= 5.0, < 6.0; fixed in 6.0

## Suggested inspection (read-only)
- Maven org.primefaces:primefaces: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.primefaces:primefaces.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j239-4gqg-5j54 (GitHub-reviewed advisory GHSA-j239-4gqg-5j54 lists affected ranges: Maven org.primefaces:primefaces >=5.0 <6.0)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2017-1000486 to the Known Exploited Vulnerabilities catalog on 2022-01-10.)

Commands are suggestions: review each one before running it.

Loading voting…