Skip to content

← Actionable
Medium, CVSS 5.3amended

Products.CMFPlone XSS in profile home_page property

CVE-2017-1000482GHSA-859j-668v-mrr6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (products-cmfplone 5.1.0, 5.0.10, 4.3.17; plone 5.1.0, 4.3.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI products-cmfplone

    Affected
    < 4.3.17>= 5.0.0, < 5.0.10>= 5.1a1, < 5.1.0
    Fixed in
    5.0.10, 5.1.0, 4.3.17
  • PyPI plone

    Affected
    >= 2.5a1, < 4.3.16>= 5.0a1, < 5.1.0
    Fixed in
    5.1.0, 4.3.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2017-1000482: 0.56% estimated exploitation activity in the next 30 days; percentile 46.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A member of the Plone site could set javascript in the homepage property of their profile, and have this executed when a visitor clicks the home page link on the author page.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-859j-668v-mrr6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-859j-668v-mrr6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-1000482

Advisory: Products.CMFPlone XSS in profile home_page property
IDs: CVE-2017-1000482, GHSA-859j-668v-mrr6
Record: https://patchnext.com/advisories/cve-2017-1000482 (revision 3, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: products-cmfplone 5.1.0, 5.0.10, 4.3.17; plone 5.1.0, 4.3.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI products-cmfplone: affected < 4.3.17; >= 5.0.0, < 5.0.10; >= 5.1a1, < 5.1.0; fixed in 5.0.10, 5.1.0, 4.3.17
- PyPI plone: affected >= 2.5a1, < 4.3.16; >= 5.0a1, < 5.1.0; fixed in 5.1.0, 4.3.16

## Suggested inspection (read-only)
- `python -m pip show products-cmfplone`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show plone`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on products-cmfplone, plone.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-859j-668v-mrr6 (OSV record GHSA-859j-668v-mrr6 lists affected ranges: PyPI products-cmfplone >=0 =5.0.0 =5.1a1 =2.5a1 =5.0a1 <5.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-859j-668v-mrr6 (GitHub-reviewed advisory GHSA-859j-668v-mrr6 lists affected ranges: PyPI products-cmfplone >=0 =5.0.0 =5.1a1 =2.5a1 =5.0a1 <5.1.0)

Commands are suggestions: review each one before running it.

Loading voting…