Samlify vulnerable to Authentication Bypass by allowing tokens to be reused with different usernames
CVE-2017-1000452GHSA-8jjf-w7j6-323c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (samlify 2.4.0-rc5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm samlify
- Affected
- < 2.4.0-rc5
- Fixed in
- 2.4.0-rc5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8jjf-w7j6-323c lists affected ranges: npm samlify >=0 <2.4.0-rc5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8jjf-w7j6-323c lists affected ranges: npm samlify >=0 <2.4.0-rc5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-1000452: 1.38% estimated exploitation activity in the next 30 days; percentile 72.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of samlify prior to 2.4.0-rc5 are vulnerable to Authentication Bypass. The package fails to prevent XML Signature Wrapping, allowing tokens to be reused with different usernames. A remote attacker can modify SAML content for a SAML service provider without invalidating the cryptographic signature, which may allow attackers to bypass primary authentication for the affected SAML service provider. Recommendation Upgrade to version 2.4.0-rc5 or later
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8jjf-w7j6-323c
- Revision 1 · created ·
Published from osv record GHSA-8jjf-w7j6-323c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-1000452 Advisory: Samlify vulnerable to Authentication Bypass by allowing tokens to be reused with different usernames IDs: CVE-2017-1000452, GHSA-8jjf-w7j6-323c Record: https://patchnext.com/advisories/cve-2017-1000452 (revision 2, source checked 26 Oct 2026, 12:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: samlify 2.4.0-rc5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm samlify: affected < 2.4.0-rc5; fixed in 2.4.0-rc5 ## Suggested inspection (read-only) - `npm ls samlify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on samlify. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8jjf-w7j6-323c (OSV record GHSA-8jjf-w7j6-323c lists affected ranges: npm samlify >=0 <2.4.0-rc5 (fixed)) - Verified: https://github.com/advisories/GHSA-8jjf-w7j6-323c (GitHub-reviewed advisory GHSA-8jjf-w7j6-323c lists affected ranges: npm samlify >=0 <2.4.0-rc5) Commands are suggestions: review each one before running it.
Loading voting…