Skip to content

← Actionable
High, CVSS 7.8amended

fs-git command injection vulnerability

CVE-2017-1000451GHSA-wp3j-gv53-4pg8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fs-git 1.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm fs-git

    Affected
    < 1.0.2
    Fixed in
    1.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-1000451: 0.76% estimated exploitation activity in the next 30 days; percentile 55.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

fs-git is a file system like api for git repository. The fs-git version 1.0.1 module relies on childprocess.exec, however, the buildCommand method used to construct exec strings does not properly sanitize data and is vulnerable to command injection across all methods that use it and call exec.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wp3j-gv53-4pg8

  2. Revision 1 · created ·

    Published from osv record GHSA-wp3j-gv53-4pg8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-1000451

Advisory: fs-git command injection vulnerability
IDs: CVE-2017-1000451, GHSA-wp3j-gv53-4pg8
Record: https://patchnext.com/advisories/cve-2017-1000451 (revision 2, source checked 26 Oct 2026, 12:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fs-git 1.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fs-git: affected < 1.0.2; fixed in 1.0.2

## Suggested inspection (read-only)
- `npm ls fs-git --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fs-git.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wp3j-gv53-4pg8 (OSV record GHSA-wp3j-gv53-4pg8 lists affected ranges: npm fs-git >=0 <1.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-wp3j-gv53-4pg8 (GitHub-reviewed advisory GHSA-wp3j-gv53-4pg8 lists affected ranges: npm fs-git >=0 <1.0.2)

Commands are suggestions: review each one before running it.

Loading voting…