pysaml2 Improper Authentication vulnerability
CVE-2017-1000433GHSA-924m-4pmx-c67h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pysaml2 4.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pysaml2
- Affected
- < 4.5.0
- Fixed in
- 4.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-924m-4pmx-c67h lists affected ranges: PyPI pysaml2 >=0 <4.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-924m-4pmx-c67h lists affected ranges: PyPI pysaml2 >=0 <4.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2017-1000433: 2.54% estimated exploitation activity in the next 30 days; percentile 85.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
pysaml2 version 4.4.0 and older accept any password when run with python optimizations enabled. This allows attackers to log in as any user without knowing their password.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-924m-4pmx-c67h
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-924m-4pmx-c67h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-1000433 Advisory: pysaml2 Improper Authentication vulnerability IDs: CVE-2017-1000433, GHSA-924m-4pmx-c67h Record: https://patchnext.com/advisories/cve-2017-1000433 (revision 3, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pysaml2 4.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pysaml2: affected < 4.5.0; fixed in 4.5.0 ## Suggested inspection (read-only) - `python -m pip show pysaml2`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pysaml2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-924m-4pmx-c67h (OSV record GHSA-924m-4pmx-c67h lists affected ranges: PyPI pysaml2 >=0 <4.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-924m-4pmx-c67h (GitHub-reviewed advisory GHSA-924m-4pmx-c67h lists affected ranges: PyPI pysaml2 >=0 <4.5.0) Commands are suggestions: review each one before running it.
Loading voting…