Skip to content

← Actionable
Medium, CVSS 5.9

Jenkins Swarm Plugin Client vulnerable to man-in-the-middle attacks

CVE-2017-1000402GHSA-pj45-8vhc-mh2f

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.jvnet.hudson.plugins:swarm-plugin

    Affected
    <= 1.5
    Fixed in
    no fixed version recorded
  • Maven org.jenkins-ci.plugins:swarm-client

    Affected
    <= 3.4
    Fixed in
    3.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2017-1000402: 0.49% estimated exploitation activity in the next 30 days; percentile 42.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins Swarm Plugin Client 3.4 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pj45-8vhc-mh2f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-1000402

Advisory: Jenkins Swarm Plugin Client vulnerable to man-in-the-middle attacks
IDs: CVE-2017-1000402, GHSA-pj45-8vhc-mh2f
Record: https://patchnext.com/advisories/cve-2017-1000402 (revision 1, source checked 26 Oct 2026, 16:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.jenkins-ci.plugins:swarm-client 3.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jvnet.hudson.plugins:swarm-plugin: affected <= 1.5
- Maven org.jenkins-ci.plugins:swarm-client: affected <= 3.4; fixed in 3.5

## Suggested inspection (read-only)
- Maven org.jvnet.hudson.plugins:swarm-plugin: check the installed version with your package manager.
- Maven org.jenkins-ci.plugins:swarm-client: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jvnet.hudson.plugins:swarm-plugin, org.jenkins-ci.plugins:swarm-client.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pj45-8vhc-mh2f (GitHub-reviewed advisory GHSA-pj45-8vhc-mh2f lists affected ranges: Maven org.jenkins-ci.plugins:swarm-client >=0 =0 <=1.5)

Commands are suggestions: review each one before running it.

Loading voting…