Skip to content

← Actionable
Unrated

memory overread when parsing invalid NAPTR responses

CVE-2017-1000381

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • runtime node

    Affected
    >= 8.0.0, < 8.1.4>= 7.0.0, < 7.10.1>= 4.0.0, < 4.8.4>= 6.0.0, < 6.11.1>= 5.0.0, < 6.0.0
    Fixed in
    4.8.4, 7.10.1, 6.11.1, 8.1.4

Sources

  • nodejs.org runtime security intelligence

    The nodejs.org release index dates the first patched release for CVE-2017-1000381 to 2017-07-10.

    VerifiedObserved Official nodejs.org release index (dist/index.json).

  • raw.githubusercontent.com runtime security intelligence

    Node.js security working group core entry 1 lists CVE-2017-1000381 affecting node >=8.0.0 =7.0.0 =4.0.0 =6.0.0 =5.0.0 <6.0.0 (no patch)

    VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2017-1000381: 3.31% estimated exploitation activity in the next 30 days; percentile 88.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The c-ares function ares_parse_naptr_reply(), which is used for parsing NAPTR responses, could be triggered to read memory outside of the given input buffer if the passed in DNS response packet was crafted in a particular way.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · published ·

    Published from vendor_advisory record nodejs-security-wg:core:1

  2. Revision 1 · created ·

    Created from vendor_advisory record nodejs-security-wg:core:1

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-1000381

Advisory: memory overread when parsing invalid NAPTR responses
IDs: CVE-2017-1000381
Record: https://patchnext.com/advisories/cve-2017-1000381 (revision 2, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: node 8.1.4, 7.10.1, 6.11.1, 4.8.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- runtime node: affected >= 8.0.0, < 8.1.4; >= 7.0.0, < 7.10.1; >= 4.0.0, < 4.8.4; >= 6.0.0, < 6.11.1; >= 5.0.0, < 6.0.0; fixed in 4.8.4, 7.10.1, 6.11.1, 8.1.4

## Suggested inspection (read-only)
- runtime node: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2017-1000381 to 2017-07-10.)
- Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/1.json (Node.js security working group core entry 1 lists CVE-2017-1000381 affecting node >=8.0.0 =7.0.0 =4.0.0 =6.0.0 =5.0.0 <6.0.0 (no patch))

Commands are suggestions: review each one before running it.

Loading voting…