Skip to content

← Actionable
High, CVSS 7.5

Security Constraint Bypass in Spring Security

CVE-2016-9879GHSA-v35c-49j6-q8hq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security:spring-security-core 4.2.1.RELEASE, 4.1.4.RELEASE, 3.2.10.RELEASE), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-v35c-49j6-q8hq lists affected ranges: Maven org.springframework.security:spring-security-core >=0 =4.0.0.RELEASE =4.2.0.RELEASE <4.2.1.RELEASE

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2016-9879: 1.46% estimated exploitation activity in the next 30 days; percentile 73.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Spring Security does not consider URL path parameters when processing security constraints. By adding a URL path parameter with an encoded "/" to a request, an attacker may be able to bypass a security constraint. The root cause of this issue is a lack of clarity regarding the handling of path parameters in the Servlet Specification (see below). Some Servlet containers include path parameters in the value returned for getPathInfo() and some do not. Spring Security uses the value returned by getPathInfo() as part of the process of mapping requests to security constraints. The unexpected presence of path parameters can cause a constraint to be bypassed. Users of Apache Tomcat (all current versions) are not affected by this vulnerability since Tomcat follows the guidance previously provided by the Servlet Expert group and strips path parameters from the value returned by getContextPath(), getServletPath() and getPathInfo() [1]. Users of other Servlet containers based on Apache Tomcat…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v35c-49j6-q8hq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-9879

Advisory: Security Constraint Bypass in Spring Security
IDs: CVE-2016-9879, GHSA-v35c-49j6-q8hq
Record: https://patchnext.com/advisories/cve-2016-9879 (revision 1, source checked 26 Oct 2026, 16:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.springframework.security:spring-security-core 4.2.1.RELEASE, 4.1.4.RELEASE, 3.2.10.RELEASE. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.security:spring-security-core: affected < 3.2.10.RELEASE; >= 4.0.0.RELEASE, < 4.1.4.RELEASE; >= 4.2.0.RELEASE, < 4.2.1.RELEASE; fixed in 3.2.10.RELEASE, 4.2.1.RELEASE, 4.1.4.RELEASE

## Suggested inspection (read-only)
- Maven org.springframework.security:spring-security-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.security:spring-security-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v35c-49j6-q8hq (GitHub-reviewed advisory GHSA-v35c-49j6-q8hq lists affected ranges: Maven org.springframework.security:spring-security-core >=0 =4.0.0.RELEASE =4.2.0.RELEASE <4.2.1.RELEASE)

Commands are suggestions: review each one before running it.

Loading voting…